Skip to:
Content

BuddyPress.org

Opened 14 years ago

Closed 14 years ago

#2163 closed defect (bug) (worksforme)

Fatal Error in Groups if Activity Streams disabled in admin

Reported by: snark's profile snark Owned by:
Milestone: 1.2.2 Priority: major
Severity: Version:
Component: Keywords:
Cc:

Description

Following-up on this thread -- http://buddypress.org/forums/topic/bp-12-is-a-fatal-error -- I just tested this on a dev site with WP2.9.1 single user and BP 1.2 and confirmed the error is still happening. If Activity Streams are disabled, the Groups still open by default to a "Home" tab that thinks there should be a Group Activity Stream displayed:

Fatal error: Call to undefined function: bp_activity_post_form_action() in /var/www/vhosts/.../httpdocs/wp-content/plugins/buddypress/bp-themes/bp-default/activity/post-form.php  on line 1

And a follow-up question I have on this is, if the Group Activity Stream is turned off, what <em>should</em> be displayed on the Home tab? I would argue in favor of having the Group Forum list be the default Group home page if Activity Streams are disabled, just as I think there should be a way to fairly easily choose the Forum list as the Group home page even if the Activity Streams are NOT disabled, just as site-wide you have the option of having the blog or the Activity Stream on the home page of the site. (This latter point is the crux of another trac ticket I filed: http://trac.buddypress.org/ticket/2144 )

Change History (4)

#1 @apeatling
14 years ago

  • Resolution set to fixed
  • Status changed from new to closed

Fixed in 1.2.1 please upgrade.

#2 @apeatling
14 years ago

Also, create a new template in groups/single/ called home.php and this will be displayed instead. It's not idea to fall back to something else since the forum could be disabled and the list of members as a fallback is fairly poor.

#3 @snark
14 years ago

  • Resolution fixed deleted
  • Status changed from closed to reopened

I was already running 1.2.1 (sorry I wrote 1.2), and now I just installed trunk#2829 and the problem is still there. I am also already using groups/single/home.php in my child theme.

#4 @apeatling
14 years ago

  • Resolution set to worksforme
  • Status changed from reopened to closed

The fix for this is in the bp-default theme. So if you have copied this over prior to the fix, you will need to update your home.php template file to match the one in bp-default. This will fix the error.

I meant to say include a "front.php" template file that will be used in activity streams are disabled.

Note: See TracTickets for help on using tickets.