Skip to:
Content

BuddyPress.org

Opened 11 years ago

Closed 11 years ago

#2124 closed defect (bug) (fixed)

class selected for home with activity stream

Reported by: arturo84 Owned by:
Milestone: 1.2.3 Priority: major
Severity: Version:
Component: Activity Keywords: needs-feedback, navigation, home, activity stream
Cc:

Description

in the new default theme with the activity on homepage the "home" link in the header navigation is not selected, if i don't set anything i don't have problem.

The bp_is_front_page conditional does not seem to be working in this scenario. (Settings > Reading > A static page > Front page > "Activity Stream")

Change History (13)

#1 @apeatling
11 years ago

  • Milestone changed from 1.2.3 to 1.2.2

#2 @apeatling
11 years ago

I've tested this on my local install and the home tab seems to select just fine - it also works on testbp.org

Can you provide exact steps to reproduce please?

#3 @arturo84
11 years ago

  • i've created a Blog page
  • in settings -> reading i've set: "front page -> activity stream" and "posts page -> Blog" ... save changes.

with this "configuration" home is not selected when i'm on homepage.

this is the 3d on the forum: http://buddypress.org/forums/topic/home-tab-not-have-class-selected

if you need a demo tell me and i set it on bp italy, thanks.

#4 @apeatling
11 years ago

  • Resolution set to worksforme
  • Status changed from new to closed

I can't reproduce this on single WP or WPMU. Are you using the default theme? If not please test that first. If you're using a custom theme or child theme it could be because of an outdated header.php file.

#5 @arturo84
11 years ago

  • Resolution worksforme deleted
  • Status changed from closed to reopened

i use the default theme and i've it online at http://www.buddypress-it.it

#6 @arturo84
11 years ago

sorry for the double post, if you need an admin account of ftp access tell me and i create one.

#7 @apeatling
11 years ago

The theme looks modified, can you please try it with a fresh clean copy of bp-default?

#8 @arturo84
11 years ago

i've tested a fresh clean copy of bp-default, and now is online, but the problem persists.

the modified version have only the last post from the blog and css changes

#9 @apeatling
11 years ago

  • Keywords needs-feedback added
  • Milestone changed from 1.2.2 to 1.2.3

Bumping this because I can't reproduce, can anyone else?

#10 @arturo84
11 years ago

  • Component set to Activity

i've this problem on bpit (mediatemple server) and locally with MAMP PRO server, i don't know if this is a usefull information...

#11 @ousep
11 years ago

This now seems to be a problem on testbp.org too, since the change to WP (not-MU).

#12 @apeatling
11 years ago

Yes I can confirm I've reproduced this.

#13 @apeatling
11 years ago

  • Resolution set to fixed
  • Status changed from reopened to closed

Fixed in 1.2 branch.

Note: See TracTickets for help on using tickets.