Skip to:
Content

Opened 9 years ago

Closed 8 years ago

#2123 closed defect (bug) (worksforme)

Groups can't have the same slugs as pages/posts

Reported by: rbl Owned by:
Milestone: 1.5 Priority: critical
Severity: Version: 1.5
Component: Core Keywords: 2nd-opinion close
Cc: ryanpc

Description

Problem: when groups are named the same way a page or a post, that page or post becomes inaccessible.

Example:
Try to visit the Example Blog Post in the news blog ( http://testbp.org/news/ ) and you'll be redirected to the homepage, because I've created a group with the same slug.

WP's slug safeguard makes perfect sense in the 1 content type world of a WP website but, IMHO, BP groups and any other content types exclusive to BP should circumvent this mechanism and allow for these duplicated slugs.

Happy debugging =)
Ricardo

Change History (6)

#1 @rbl
9 years ago

Sorry, forgot to add the link to the group:
http://testbp.org/groups/example-blog-post/

#2 @johnjamesjacoby
9 years ago

  • Component set to Core
  • Milestone set to 1.3

Move to milestone 1.3 for review.

#3 @ryanpc
9 years ago

  • Cc ryanpc added

#4 @boonebgorges
9 years ago

I can't reproduce this on BP rev 3130/WP 3.0. I've created a group, a post, and a page, all with the same title, and they're all still accessible. I even played with my permalinks to make sure that the post slug would be in the same query position as the group name - but still, I'm able to access both. Has something been fixed in BP, or is WP 3.0 being smart?

#5 @r-a-y
8 years ago

  • Keywords 2nd-opinion close added; slug group post page removed
  • Version set to 1.3

I can't reproduce this either.

To test, I:

  • am using WP 3.0.3 and BP 1.3 rev 3523.
  • changed permalinks to /%postname%/.
  • created a group called "Hello World" and "Hello world!", since WP creates a default page with title "Hello world!" and slug "hello-world".

Both groups created fine.

Can't duplicate error.

#6 @boonebgorges
8 years ago

  • Resolution set to worksforme
  • Status changed from new to closed

Thanks, r-a-y. Closing this ticket. If someone can give steps to reproduce, please reopen.

Note: See TracTickets for help on using tickets.