Skip to:
Content

Opened 9 years ago

Closed 9 years ago

#2104 closed defect (bug) (fixed)

e-mail Link shows blank page

Reported by: erich73 Owned by:
Milestone: 1.2.2 Priority: critical
Severity: Version:
Component: Keywords:
Cc:

Description

JJJ has made an activity-comment-Reply on an Activity-post I have made within a PRIVATE-Group.

Because of JJJ´s comment-Reply, I did receive an e-mail-notification, which is fine.

However, when clicking on the Link within the e-mail - I am being forwarded to a BLANK page (when I am NOT logged-in):

http://testbp.org/activity/p/68846/

forwards to:

http://testbp.org/members/erich73/activity/68846/

which is showing a BLANK page.

There should be at least a message like "Please log-in in order to see the message" instead of a blank page.

See the e-mail-notification below:

*

John James Jacoby replied to one of your updates:

"1 2 3"

To view your original update and all comments, log in and visit: http://testbp.org/activity/p/68846/


To disable these notifications please log in and go to: http://testbp.org/members/erich73/settings/notifications/

*

Change History (3)

#1 @r-a-y
9 years ago

  • Priority changed from minor to major

Confirmed.

Instead of a blank page, I think a login form should be shown with some copy saying "You need to be a member of "MY PRIVATE GROUP" to view this message. Please login now."

If you're logged-in and you are not a member of the group, you should get redirected to the private group homepage. By default, there's already a message that says "You do not have access to this activity.", so this would work great.

Bumping to major because it's an usability issue.

#2 @apeatling
9 years ago

  • Milestone changed from 1.2.3 to 1.2.2
  • Priority changed from major to critical

#3 @apeatling
9 years ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [2814]) Fixes #2104

Note: See TracTickets for help on using tickets.