Skip to:
Content

Opened 9 years ago

Closed 9 years ago

#2068 closed defect (bug) (fixed)

Sent answered messages are marked as unread

Reported by: motomac Owned by:
Milestone: 1.2.6 Priority: major
Severity: Version:
Component: Messages Keywords: has-patch dev-feedback
Cc:

Description

If I send a private message, after that I have a notification about unread message in BuddyBar. And it displays untill I open my inbox folder.

Attachments (1)

2068.001.patch (954 bytes) - added by r-a-y 9 years ago.

Download all attachments as: .zip

Change History (22)

#1 @motomac
9 years ago

  • Milestone set to 1.2.2

#2 @apeatling
9 years ago

  • Milestone changed from 1.2.3 to 1.2.2

#3 @apeatling
9 years ago

  • Resolution set to invalid
  • Status changed from new to closed

Correct. It's called a notification of a new message. :)

#4 @r-a-y
9 years ago

  • Resolution invalid deleted
  • Status changed from closed to reopened

Are you sure this isn't a defect?

I'm experiencing this on testbp.org.

I send a private message, why should my own sent message be counted as a notification?

#5 @apeatling
9 years ago

  • Resolution set to worksforme
  • Status changed from reopened to closed

Just tested this, it does not happen for me. If you are sending the message to yourself then you will get a notification.

#6 @r-a-y
9 years ago

It happens when I reply to a private message.

#7 @motomac
9 years ago

  • Component set to Activity
  • Resolution worksforme deleted
  • Status changed from closed to reopened

Bug still takes place.

#8 @apeatling
9 years ago

  • Milestone changed from 1.2.2 to 1.2.3

#9 @motomac
9 years ago

Bug still takes place in 1.2.4.

#10 @motomac
9 years ago

  • Component changed from Activity to Messaging
  • Milestone changed from 1.3 to 1.2.6
  • Summary changed from Sent messages marks as unread to Sent answered messages are marked as unread

#11 @pisanojm
9 years ago

I've looked through the trac and wonder if this is related to the a problem I am having with Private messages @Rivh!etivit said there was a trac for this... We still have the problem with 1.2.5 and 3.0 here is the buddypress.org thread:
http://buddypress.org/community/groups/how-to-and-troubleshooting/forum/topic/private-messate-notification-ghost/

#12 @nuprn1
9 years ago

the issue only happens if you reply to a message thread (even under sent message - if recipient did not respond)

the problem is caused by get_recipients() array containing the user_id for the user who sent the reply. (due to the loop with the notification)

1) send message to a different user
2) view message thread under "Sent Message"
3) reply to message
4) click to the home page (notification then displays)

@r-a-y
9 years ago

#13 @r-a-y
9 years ago

  • Keywords has-patch added

I just realized after attaching the above patch that there's a better way to block the sender from the recipient's list. Check out line 447-448 in bp-messages.php.

I'm going to look into this and provide another patch, unless someone does it before me ;)

#14 @pisanojm
9 years ago

can you provide new patch to test?

#15 @pisanojm
9 years ago

Ray, I've tried this and it appears to be working... I have a couple of users trying this... if you DON'T hear back from me here...consider it WORKING from my stand point... Great job!

#16 @motomac
9 years ago

I confirm. Patch works good.

#17 @r-a-y
9 years ago

Hey pisanojm and motomac, I got sidetracked!

The current patch works, but I would still like to provide a better patch as the current one does the check a little late in the game.

It should be made where Rich (@nuprn1) stated around line 425 in bp-messages.php or in BP_Messages_Thread::get_recipients() in bp-messages-classes.php.

#18 @r-a-y
9 years ago

  • Keywords dev-feedback added

Or maybe the current one works just fine? ;)

#19 @pisanojm
9 years ago

Ray,

Ok... possibly an issue with this.. after I put this patch on seems like now nobody get's notification or emails sent to them for notification... When I turned the patch off (i.e. back to the original) the ghosting started again, but people were being notified again...

Please check this and confirm this to be happening... I will try this again tonight in more detail.

#20 @pisanojm
9 years ago

Ray,

I've tried this extensively tonight and it DOES seem to be working correctly. I suspect, now, it was a false alarm by a USER on my site that didn't understand a couple of things. I checked it fairly throughly tonight A/B applied/unapplied and the result was consistant both in what it was supposed to fix and with regard to e-mails/notificaiton still be sent.

Sorry for the above comment. If no one else is suspecting the behavior I described above, I'd say it's good to go!

#21 @johnjamesjacoby
9 years ago

  • Resolution set to fixed
  • Status changed from reopened to closed

(In [3140]) Fixes #2068

Note: See TracTickets for help on using tickets.