Skip to:
Content

Opened 9 years ago

Closed 8 years ago

#2049 closed defect (bug) (duplicate)

Member Profile: Username with same name as installed folder fails

Reported by: intimez Owned by:
Milestone: 1.5 Priority: major
Severity: Version:
Component: Core Keywords: has-patch needs-testing dev-feedback
Cc:

Description (last modified by boonebgorges)

username = tester123
installed URL = http://www.example.com/tester123

all sub menu access (profile, messages, friends, groups, etc.) will redirect to home

clicking on user's profile will redirect to members list

[wordpress2.9.2 + buddypress 1.2.1]

Attachments (1)

2049-1.diff (520 bytes) - added by boonebgorges 8 years ago.

Download all attachments as: .zip

Change History (14)

#1 @apeatling
9 years ago

  • Resolution set to worksforme
  • Status changed from new to closed

Pleae make sure you have set up permalinks and have followed the instructions when setting permalinks and made a .htaccess file.

#2 @intimez
9 years ago

  • Resolution worksforme deleted
  • Status changed from closed to reopened

Permalinks was already configured prior to testing

Please note that to duplicate bug, the username must be the same as sub folder name as described.

#3 @apeatling
9 years ago

Ok this is a known bug, you must install in a unique folder name.

#4 @apeatling
9 years ago

  • Milestone changed from 1.2.3 to 1.2.2

Sorry - I misread, you mentioned usernames. There should be a check, I will look into this more.

#5 @apeatling
9 years ago

  • Milestone changed from 1.2.2 to 1.3

#6 @r-a-y
9 years ago

  • Component set to Core
  • Summary changed from user redirected to home to Member Profile: Username with same name as installed folder fails

Changed title to be more specific.

#7 @DJPaul
9 years ago

I still think apeatling was originally right, i needs to be installed to a unique folder name. BP ought to be checking that if the site is installed in a subdomain(s), that it prevents that name being a username.

#8 @boonebgorges
8 years ago

  • Description modified (diff)

2049-1.diff is one strategy - it only removes items from the uri_chunks if they match the position in the site path. Anyone see any problems with this approach?

@boonebgorges
8 years ago

#9 @boonebgorges
8 years ago

  • Keywords has-patch needs-testing added; user redirected home removed

#10 @boonebgorges
8 years ago

  • Keywords dev-feedback added

Bump. If anyone could give feedback on this issue, it would be much appreciated.

#11 @intimez
8 years ago

@boonebgorges

I tried this using trunk 3717 + wp 3.0.4 and it's not working. Going to any of the menu item under my account will go to 'Page Not Found'. If I click on name, it will go to all member list instead of individual profile.

#12 @DJPaul
8 years ago

This ticket is very similar to #1726 where I have commented on a potential solution.

#13 @DJPaul
8 years ago

  • Resolution set to duplicate
  • Status changed from reopened to closed

duplicate of #1726

Note: See TracTickets for help on using tickets.