Skip to:
Content

Opened 9 years ago

Closed 8 years ago

#1998 closed defect (bug) (fixed)

xprofile_set_field_data with value = array

Reported by: BB_Othella Owned by:
Milestone: 1.5 Priority: major
Severity: Version:
Component: Core Keywords: field, profile, checkboxes
Cc:

Description

When editing in a profile a checkboxes group set as required, the update of the values seems to fails, due to the trim($value) where $value is an array of the checked values (line 726 in bp-xprofile.php)

Change History (3)

#1 @johnjamesjacoby
9 years ago

  • Component set to Core
  • Milestone set to 1.3

Will need to look at this for 1.3.

#2 @boonebgorges
8 years ago

I couldn't reproduce the error, but I'm putting in a type check just in case.

#3 @boonebgorges
8 years ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [3436]) Checks to see whether is an array before checking for strlen in xprofile_set_field_data(). Fixes #1998. Props BB_Othella

Note: See TracTickets for help on using tickets.