Skip to:
Content

BuddyPress.org

Opened 14 years ago

Closed 13 years ago

#1915 closed enhancement (fixed)

Recommended change in search box default value text

Reported by: snark's profile snark Owned by:
Milestone: 1.5 Priority: minor
Severity: Version:
Component: Core Keywords: has-patch needs-testing
Cc: snark

Description

The default text within the search boxes says "Search anything..." in all of the section search boxes: Groups, Forums and Members. The problem is semantic; you can't actually "search anything" from any of those search boxes -- you can only search member nicknames from the Members search box, Group names in the Groups search box, and Forum topics from the Forums search box.

It's a very each fix to edit, for instance, the bp-core-templatetags.php file to change 'Search anything...' in the function code to something more specific, and I have done this. However, this makes three files to edit, and each time you come out with a new version of BP, they will be overwritten, and I'll have to go edit them again.

I propose changing the default search box texts to the following:

Groups search: "Search Groups..."

Forums search: "Search Topics..." (or "Search Forum Topics...")*

Members search: "Search Members..."

  • It's important to include the word "Topics", rather than just "Search Forums", because the search only works for topics, and if it says "Search anything..." like now, or even "Search Forums...", the implication is that you can do a keyword search for anything in the body of any Forum post, but that's not the case -- only hits within Topic titles are returned.

Attachments (1)

1915.patch (9.6 KB) - added by boonebgorges 14 years ago.

Download all attachments as: .zip

Change History (6)

#1 @apeatling
14 years ago

  • Milestone changed from 1.2 to 1.3

This is going to mess up AJAX, bumping this to the next version.

#2 @snark
14 years ago

Ok. In the meantime, is there any harm in me tweaking the bp-core-templatetags.php file and the other 2 similar files to make this change, or by doing so will I be somehow messing up AJAX?

#3 @boonebgorges
14 years ago

  • Component set to Core

I've written a patch that allows the default search text to be different for each component, and also allows it to be easily filtered by plugins.

Because it could break a lot of stuff, I'm posting it here before committing it. I'd appreciate if others could apply the patch to their dev installs and have a quick look to make sure that directory search is still working.

@boonebgorges
14 years ago

#4 @boonebgorges
14 years ago

  • Keywords has-patch needs-testing added; search search box search members search groups search forums removed

#5 @boonebgorges
13 years ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [3627]) Replaces generic 'Search anything' default directory search text with component-specific text. Fixes #1915. Fixes ->forums->slug so that it is properly set in the bp_pages way

Note: See TracTickets for help on using tickets.