Skip to:
Content

BuddyPress.org

Opened 14 years ago

Closed 14 years ago

#1902 closed defect (bug) (fixed)

Forum-Title / entering HTML shows strange output

Reported by: erich73's profile erich73 Owned by:
Milestone: 1.2 Priority: major
Severity: Version:
Component: Keywords:
Cc:

Description

try to post the follwing HTML into the Forum-title:
Do not use the stars at beginning and end of the HTML-code.

*<a href="http://www.heise.de/newsticker/">Heise Newsticker</a>*

Change History (8)

#1 @r-a-y
14 years ago

Images are also rendered.

The problem is with the filter being applied to bp_get_the_topic_title.

Should be using wp_filter_kses instead of bp_forums_filter_kses.

Line 7 of bp-forums-filters.php should be:

add_filter( 'bp_get_the_topic_title', 'wp_filter_kses', 1 );

#2 @apeatling
14 years ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [2658]) Fixes #1902

#3 @erich73
14 years ago

  • Resolution fixed deleted
  • Status changed from closed to reopened

not sure this is really fixed !?

see the title in my latest Forum-post at:

http://testbp.org/forums/

#4 @r-a-y
14 years ago

I noticed the strip_tags filter being applied to bp_get_the_topic_title(), why not wp_filter_kses, Andy?

#5 @r-a-y
14 years ago

My bad! Looks like you're using kses in [2659].

#6 @DJPaul
14 years ago

strip_tags let you put in a HTML tag and when it is displayed on the member list, it displayed no title (as it was being stripped). Kses stops that but allows some HTML in which isn't wanted for a forum post title.

#7 @apeatling
14 years ago

Going to move the strip_tags check to before the topic is posted. That way no HTML is allowed, but if that results in an empty title, the topic will not post.

#8 @apeatling
14 years ago

  • Resolution set to fixed
  • Status changed from reopened to closed

(In [2661]) Fixes #1902

Note: See TracTickets for help on using tickets.