Skip to:
Content

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#1878 closed defect (bug) (worksforme)

BP 1.2-RC2 for WP -- "create a new blog" showing up

Reported by: snark Owned by:
Milestone: 1.2 Priority: major
Severity: Version:
Component: Keywords: blog, user registration, needs-feedback
Cc: snark

Description

Running BP 1.2-RC2 for WP 2.9.1 single user. New user registration now showing --

Blog Details

Yes, I'd like to create a new blog

-- but there are no user user blogs in BP for single-user WP (not WPMU)! I believe this was not showing up in the beta version.

Attachments (1)

registration-screenshot.gif (14.0 KB) - added by snark 4 years ago.
registration error screenshot

Download all attachments as: .zip

Change History (9)

comment:1 snark4 years ago

  • Cc snark added

comment:2 apeatling4 years ago

I cannot reproduce this. Anyone else?

comment:3 apeatling4 years ago

  • Keywords needs-feedback added

comment:4 zoltok4 years ago

I've had the same issue. I upgraded yesterday from 1.2 beta to 1.2 RC2, and these fields now appear in my registration form where they previously didn't. Running on WP 2.9.1, but still using a theme for 1.1 (buddymatic), with backwards compatability plugin.

snark4 years ago

registration error screenshot

comment:5 snark4 years ago

I uploaded as screenshot of the registration page I'm now getting with the "Blog Details" option showing up. Again, I didn't see this in the beta, but it showed up with either RC1 or RC2.

comment:6 apeatling4 years ago

Are you using the default theme or a child theme / your own theme?

comment:7 apeatling4 years ago

  • Resolution set to worksforme
  • Status changed from new to closed

If you're using an old 1.1 theme (as you mentioned above) then these files will show. You need to add a:

<?php if ( bp_core_is_multisite() ) : ?>
 -- blog fields --
<?php endif; ?>

Around the blog fields in your theme. Please reopen this ticket if you can confirm this is happening using the default theme with no changes.

comment:8 snark4 years ago

Sorry, my mistake -- you are correct, there is no bug. I had copied the registration directory to my theme to edit the register.php and activate.php files, just to change the welcome messages. I had intended to copy the files from the BP 1.2 Default theme, but I think I must have inadvertantly copied the files from an older theme, and that's what caused the problem. Your note about "using an old 1.1 theme" tipped me off, so thanks, and sorry for the distraction.

Note: See TracTickets for help on using tickets.