Skip to:
Content

BuddyPress.org

Opened 14 years ago

Closed 14 years ago

#1812 closed defect (bug) (fixed)

Message autocomplete does not work when BuddyPress is activated on a secondary blog

Reported by: r-a-y's profile r-a-y Owned by:
Milestone: 1.5 Priority: minor
Severity: Version:
Component: Keywords:
Cc:

Description

Just tested the message automcomplete functionality when BuddyPress is activated on a secondary blog, it doesn't work.

When reverting BP on the root blog, message autocomplete works.

Change History (10)

#1 @r-a-y
14 years ago

To be clear, when BP is on a secondary blog, the AJAX returns nothing for the compose message "Send to" autocomplete field.

#2 @apeatling
14 years ago

Worked fine for me with BP_ENABLE_MULTIBLOG turned on and using bp-default.

#3 @apeatling
14 years ago

  • Resolution set to worksforme
  • Status changed from new to closed

It also worked when setting BP_ROOT_BLOG to a sub blog. Make sure you have either one of the settings enabled in your wp-config.php before trying to enable on a sub blog.

#4 @r-a-y
14 years ago

I have BP_ROOT_BLOG defined in bp-custom.php. Just tried putting BP_ROOT_BLOG in wp-config.php and have the same result.

Not sure what's wrong. Using the bp-default theme to test as well.

Upgrading to trunk to see if this might fix it.

#5 @r-a-y
14 years ago

Just upgraded to trunk.
Still the same.

I'm going to ask the guys on the forums to see if they experience the same issue.

#6 @miguael
14 years ago

  • Resolution worksforme deleted
  • Status changed from closed to reopened

I am on trunk as well with BP_ROOT_BLOG in wp-config.php and have the same problem as r-a-y described...

#7 @r-a-y
14 years ago

Just going to add one further detail from my end, I have WPMU setup as a subdirectory install.

#8 @apeatling
14 years ago

WPMU in subdirectory with BP_ROOT_BLOG set as a sub blog, logged in, head to messages, typed a friends name and it popped up fine. I can't reproduce this guys, sorry.

#9 @apeatling
14 years ago

  • Milestone changed from 1.2 to 1.2.1

Punting this to 1.2.1 since it's not hugely critical and we can work out steps to reproduce later.

#10 @johnjamesjacoby
14 years ago

  • Resolution set to fixed
  • Status changed from reopened to closed

(In [3028]) Fixes #2422, #1812 props r-a-y

Note: See TracTickets for help on using tickets.