Skip to:
Content

Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#1808 closed defect (bug) (fixed)

Buddypress 1.2 beta and bbpress autoinstall

Reported by: brokenforum Owned by:
Milestone: 1.2 Priority: major
Severity: Version:
Component: Keywords:
Cc:

Description

It run fine with Buddypress 1.13 when i upgrade to Buddypress 1.2 beta the "forums" directory shows a blank screen, however you can see and load the BBpress in the root/wp-content/plguins/buddypress/bp-forums/bbpress directory. If i downgrade Buddypress to 1.13 the forum works fine.

External install of BBpress also works, just not autoupgrade.

Any hint?

Change History (7)

#1 @apeatling
9 years ago

  • Resolution set to worksforme
  • Status changed from new to closed

If you're upgrading make sure you installed the backwards compatibility plugin. Check with the new default theme and see if that works first.

#2 @brokenforum
9 years ago

  • Resolution worksforme deleted
  • Status changed from closed to reopened

Nope, tried with BuddyPress Backwards Compatibilty 0.5 and 0.5.1 on second server, still same error pops. Forums dir is just blank.

#3 @cnorris23
9 years ago

  • Keywords needs-patch added

This happens on a fresh install too. Running WordPress standalone 2.9.1, and 3.0-alpha, both running the latest trunk. One site is running PHP 5.3, and the other 5.2.11. The issue happens on initial group creation, and if you go to the group admin to enable the forums. I can get the setting to change to enable the forum through the group admin, but I get a blank screen after saving the settings. If I go back and refresh the page, the forum link shows up, but when you try to visit the forum, you get a blank screen again. I started digging around to see if I can find the problem, but I haven't gotten very far as things keep coming up. I was waiting until I found the source of the issue, before I created a ticket, and was surprised no one else had run across this.

#4 @cnorris23
9 years ago

  • Keywords reporter-feedback added; needs-patch removed

So I was wrong about getting the blank screen on 2.9.1. After hours of sifting through the code, I decided to try WP 2.9.1 again, and it worked. That meant that it had something to do with my WP 3.0-alpha install. I did a few svn reverts until I was able to narrow it down to trunk revision 12923, which turns out to be permalink fixes for custom post types. Now that I've found out the issue, I'm going to take a break, but I'm guessing it has something to do with a class between bbPress query_vars, and WP 3.0's new way of dealing with them.

@brokenforum,
What version of WP are you using?

#5 @brokenforum
9 years ago

  • Resolution set to fixed
  • Status changed from reopened to closed

Issue fixed.

Issue conflict with mystique theme, using same functions as buddypress

Functionname: search_form();

#6 @brokenforum
9 years ago

Idea it would be better that buddypress core used bp_search_form() insteed of search_form as it could conflict with wordpress search template function.

#7 @cnorris23
9 years ago

  • Keywords reporter-feedback removed

You should talk to the template designer, as this is their issue. The default template does not use the search_form() function, and the same with core. There is, also, already a bp_search_form() function. There are also a number of other *_search_form() functions. You may want to do a code search to find the one that's right for your situation/theme.

Note: See TracTickets for help on using tickets.