Skip to:
Content

BuddyPress.org

Opened 14 years ago

Closed 14 years ago

#1777 closed defect (bug) (fixed)

Variable 'user_dataset' left undefined

Reported by: cnorris23's profile cnorris23 Owned by:
Milestone: 1.2 Priority: blocker
Severity: Version:
Component: Keywords: groups
Cc:

Description

In [2537], the variable 'user_dataset' was almost removed. However, since it wasn't completely removed, it's breaking a couple of the group functions. It was left in the delete() function of bp-groups-classes.php, and in groups_notification_group_updated() function of bp-groups-notifications.php. This causes three things:
1) An error (which I can't remember how to reproduce, but it's how I found the issue) about something wrong with the for() statement on line 9 of bp-groups-notifications.php
2) Trying to update the "notify users on group changes" option will not work, and usually (I think this might have been where I got the error originally) results in a blank (white) screen.
3) Because of it's appearance in the delete() function, when you delete a group, the bp_groups_members table is not updated, so users are still listed as being part of non-existent groups.

Change History (1)

#1 @apeatling
14 years ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [2556]) Fixes #1777

Note: See TracTickets for help on using tickets.