Skip to:
Content

Opened 4 years ago

Closed 4 years ago

#1718 closed defect (bug) (worksforme)

Call to undefined function bp_page_title()

Reported by: grosbouff Owned by:
Milestone: 1.2.3 Priority: major
Severity: Version:
Component: Core Keywords: reporter-feedback
Cc:

Description

When I register a new user and they I try to activate it
(/wordpress-mu/wp-activate.php?key=...); I got

Fatal error: Call to undefined function bp_page_title() in F:\web\kinetest\wordpress-mu\wp-content\themes\bp-default\header.php on line 9

Change History (7)

comment:1 johnjamesjacoby4 years ago

This function is included in the BuddyPress core template tags file, so there's no reason why if BuddyPress is activated that this error is happening.

I noticed you're using the old bp-default theme, located in wp-content/themes. Is it possible that your theme needs to be updated?

comment:2 cnorris234 years ago

  • Keywords reporter-feedback added

comment:3 apeatling4 years ago

  • Resolution set to worksforme
  • Status changed from new to closed

comment:4 grandeped4 years ago

  • Component set to Core
  • Resolution worksforme deleted
  • Status changed from closed to reopened

I am getting the same error:

Fatal error: Call to undefined function: bp_page_title() in /home/txdla2/public_html/wp-content/themes/txdla/header.php on line 9

That only seems to happen on the "wp-activate.php?key=" page when a new user registers. BuddyPress is activated. "txdla" is a custom child theme of BuddyPress Default 1.2.5.2. As far as I can tell, the parent theme is updated. Any other suggestions for what could be wrong?

comment:5 johnjamesjacoby4 years ago

Can you confirm if this problem happens when you're using the bp-default theme?

comment:6 grandeped4 years ago

Yes - just switched to the bp-default theme and it is still happening.

comment:7 grandeped4 years ago

  • Resolution set to worksforme
  • Status changed from reopened to closed

Found the solution. I was also have problems with the template on all pages - the sidebar was disappearing. I looked in the child theme folder and there was an entire set of folders for "members" "groups" "register" etc. These came from an older version, but I never edited those or added them. Deleting those corrected the sidebar problem. I tried adding a new member and that worked.

So, even though I had the updated template files, older template files had been copied over to my child theme BEFORE the update. Anyone else with this problem should check to make sure that older template files weren't copied over inadvertently before the update.

Note to anyone else with this problem - the link to activate a new member should be to "http://yoursite.com/active?key=[keystring]" NOT "http://yoursite.com/wp-active.php?key=[keystring]". You can actually update the link manually (leaving the key string in tact) and activation will still work.

Note: See TracTickets for help on using tickets.