Skip to:
Content

Opened 9 years ago

Closed 5 years ago

#1656 closed defect (bug) (worksforme)

Probably not a "bug", but there's a link issue when changing the blog url, or at least it's not consistent.

Reported by: jonc_123 Owned by:
Milestone: Priority: minor
Severity: normal Version:
Component: Core Keywords:
Cc:

Description

I was messing around yesterday with my blog url and noticed that the URL used in the activity links is different from the menu links at the top when I changed it.

I changed the path on a blog from /wordpress-mu to /main, and the links were pointing to the "/main" on the menu but not on the user accounts in the latest activity which were still at "/wordpress-mu". I had not changed the .htaccess at the time, which fixed everything, but just noticed a difference on how the links were being created.

Change History (4)

#1 @r-a-y
9 years ago

  • Type changed from enhancement to defect

Bumping this to defect, so it's seen by the BP devs.

I haven't tried to reproduce it, but it sounds like a bug to me.

#2 @apeatling
9 years ago

  • Milestone changed from 1.2 to 1.3

There is no support in the activity stream for updating links since the activity at the moment is recorded at the time it was done. There may be a refresh option in a future version, but right now you are going to run into problems if you change your site domain with existing activity stream data. It is possible to use find and replace via an sql query though.

#3 @boonebgorges
8 years ago

  • Component set to Core
  • Milestone changed from 1.3 to Future Release

I'd like to see the refresh option that apeating suggests but we won't have time for it for 1.3

#4 @boonebgorges
5 years ago

  • Milestone Future Release deleted
  • Resolution set to worksforme
  • Severity set to normal
  • Status changed from new to closed

Activity action strings, including links, are now dynamically generated. See #3856.

Note: See TracTickets for help on using tickets.