Skip to:
Content

BuddyPress.org

Opened 13 years ago

Closed 13 years ago

#1643 closed defect (bug) (fixed)

Reply button - (X) not linking due to span tag

Reported by: ezd's profile Ezd Owned by:
Milestone: 1.2 Priority: minor
Severity: Version:
Component: Keywords:
Cc: hempsworth

Description

Me and others have noticed that you sometimes have to click twice on the reply-button in order for the comment field to open. The problem seems to happen randomly. Any fix for this?

Change History (15)

#1 @hempsworth
13 years ago

I haven't experienced this before, could you be more specific on when this occurs? Specifically, what browsers this happens in?

#2 @hempsworth
13 years ago

  • Cc hempsworth added

#3 @apeatling
13 years ago

  • Keywords reporter-feedback added

Need steps to reproduce.

#4 @apeatling
13 years ago

  • Priority changed from major to minor

#5 @Ezd
13 years ago

It might be a browser thing. Right now I'm testing it with Safari 4.0.4 (latest) and Firefox (latest). I usually experience this in the Profile and with Safari 4.0.4. Today I had a session where I had to click the reply button 3 times for it to open (Safari browser again). And sometimes only 2 times. I know it's not easy to reproduce as it seems to be random.

#6 @Ezd
13 years ago

  • Keywords reporter-feedback removed

#7 follow-up: @haloid
13 years ago

I don't think this is the correct wording of the bug. In fact I don't think it's a new bug at all. It's related to your other ticket: http://trac.buddypress.org/ticket/1633. If you click on the '(0)' it won't work, but if you click on the "Reply" word it will work. Try it.

#8 in reply to: ↑ 7 @haloid
13 years ago

But if you click anywhere else on the orange area it will work, just not on the "(x)"

#9 @Ezd
13 years ago

Wow nice catch haloid. Thats excactly what it is!

I think this is a very annoying bug and it's related to my other ticket yes. (X) isn't linkable on the Reply button or in the Optionbar where (X) is.

Hope this will be fixed soon.

#10 @Ezd
13 years ago

  • Keywords needs-patch added

#11 @Ezd
13 years ago

The reply button needs to be working no matter where you decide to click on it.

#12 @r-a-y
13 years ago

It's because the (x) is enclosed with a [span] tag.
I removed the span tag in Firebug and it works now.

I'm guessing Andy put the [span] tag in there for theme developers.

#13 @Ezd
13 years ago

  • Keywords needs-patch removed

Ok tnx, thats the solution then. Lets hope Andy will fix this in the default theme then.

#14 @Ezd
13 years ago

  • Summary changed from Reply button - click twice to Reply button - (X) not linking due to span tag

#15 @apeatling
13 years ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [2498]) Fixes #1643

Note: See TracTickets for help on using tickets.