Skip to:
Content

BuddyPress.org

Opened 13 years ago

Closed 12 years ago

#1642 closed enhancement (duplicate)

Exclude Members from Lists

Reported by: developdaly's profile developdaly Owned by:
Milestone: 1.5 Priority: major
Severity: Version:
Component: Core Keywords:
Cc:

Description

A nice parameter to have would be one that allowed exclusion of specific items from lists.

So you'd have something like this:

bp_group_has_members( group_id=1&exlcude_member=1' )

or

bp_group_has_members( group_id=1&exlcude_member=1,2,3' )

The same could work for blog lists or general member lists.

Playing off of how wp_list_pages() works, these parameters could either exclude or include.

Change History (2)

#1 @DJPaul
13 years ago

ith regards to #1642 it'd be good if the exclude parameter was a bit smart. For example, bp_has_site_members(), would be nice to be able to filter against xprofile fields values

#2 @boonebgorges
12 years ago

  • Component set to Core
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #2641 and #2620.

Note: See TracTickets for help on using tickets.