Skip to:
Content

BuddyPress.org

Opened 13 years ago

Closed 13 years ago

#1638 closed defect (bug) (fixed)

atme @ notification_activity_new_mention - email notifications do not work

Reported by: nuprn1's profile nuprn1 Owned by:
Milestone: 1.2 Priority: major
Severity: Version:
Component: Keywords:
Cc:

Description

bp_activity_at_message_notification does not fire on the add_action( 'bp_activity_posted_update', 'bp_activity_at_message_notification', 10, 3 );

modifying function bp_activity_post_update( $args = )

and adding this snip seems to work

/* Send an email notification if settings allow */
require_once( BP_PLUGIN_DIR . '/bp-activity/bp-activity-notifications.php' );
bp_activity_at_message_notification( $content, $user_id, $activity_id );

Attachments (1)

atme.gif (10.0 KB) - added by nuprn1 13 years ago.

Download all attachments as: .zip

Change History (9)

#1 @apeatling
13 years ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [2387]) Fixes #1638 - email notifications of @ messages.

#2 @luccame
13 years ago

  • Resolution fixed deleted
  • Status changed from closed to reopened

I still can't get email notification when the mention is made in a comment.
Works fine if mentions are done in a fresh activity update.
Not sure if this is the intended behavior...

#3 @nuprn1
13 years ago

i think that is intended behavior, if you look at the function bp_activity_new_comment on bp-activity.php - you can see nothing is calling for @atme - just a regular notification for new comments.

#4 @nuprn1
13 years ago

I just tested the fix but still not sending out an @atme email with the action hook

#5 @apeatling
13 years ago

  • Resolution set to worksforme
  • Status changed from reopened to closed

Emails are only sent on a regular profile update, not in comments.

#6 @nuprn1
13 years ago

  • Resolution worksforme deleted
  • Status changed from closed to reopened

still no email notifications when an activity with @whatever is posted with latest trunk (1.2) on single wp install.

Also when logging in, the @whatever Mentions (1 new) when clicking on that tab - no activity is shown just: Sorry, there was no activity found. Please try a different filter.

@nuprn1
13 years ago

#7 @nuprn1
13 years ago

ok, i found out why no atme activity was being displayed in the loop - the activity update was made to a private forum and in the db the sitewide flag was set.

is there a way to cross reference if an user is a member of a private forum and then display the @mention activity in the loop?

#8 @apeatling
13 years ago

  • Resolution set to fixed
  • Status changed from reopened to closed

(In [2463]) Fixes #1638

Note: See TracTickets for help on using tickets.