Skip to:
Content

BuddyPress.org

Opened 14 years ago

Closed 14 years ago

#1598 closed defect (bug) (fixed)

Bug: admin notices broken

Reported by: _dorsvenabili's profile _DorsVenabili Owned by:
Milestone: 1.2 Priority: major
Severity: Version:
Component: Keywords: notices admin
Cc:

Description

I installed latest trunk buddypress. If I'm logged as the global admin, I go to http://example.com/members/admin/messages/compose/ I compose a new message and I click on 'This is a notice to all users.'. The notice will NOT be sent and the admin will see in the Notices screen all the notices sent but without title, subject, etc. and with the wrong date (1/1/1970).

Attachments (1)

Screenshot-notices.png (85.9 KB) - added by _DorsVenabili 14 years ago.
admin notices screen

Download all attachments as: .zip

Change History (3)

@_DorsVenabili
14 years ago

admin notices screen

#1 @jivany
14 years ago

This appears to work ok in WP Single 2.9.1 with r2392 but does not work in WPMU 2.9.1.

One note about WP Single - In my quick test, the Notifications in the top admin bar did not change to indicate that there was a new message for the user (no count, nothing in dropdown). Works fine for direct messages though.

Even more concerning in WPMU is that in my testing, the Notice doesn't show up anywhere. It's not in the admin's "Sent Messages" or Inbox or in any other user's. It just disappears. What is really strange is if I go to the admin's "Notices" tab, I see the_excerpt() output for the most recent post on the main blog. I get one copy for each of the Notification messages I attempted. Date info and other missing data is the same as what _DorsVenabili reported.

In WPMU, direct messages work fine.

#2 @apeatling
14 years ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [2397]) Fixes #1598 - broken sitewide notices

Note: See TracTickets for help on using tickets.