Skip to:
Content

BuddyPress.org

Opened 15 years ago

Closed 13 years ago

#1583 closed defect (bug) (fixed)

BuddyBar wrong when viewing group

Reported by: johnjamesjacoby's profile johnjamesjacoby Owned by:
Milestone: 1.5 Priority: minor
Severity: normal Version:
Component: Groups Keywords:
Cc:

Description

When you view a group, the BuddyBar admin for groups changes to that specific groups menu items.

Haven't researched, haven't looked for dupe tickets. Just noting this here as a reminder. Happens on testbp.org and in current trunk.

Change History (4)

#1 @r-a-y
14 years ago

This happens in 1.1 as well.
Is it a feature?

#2 @apeatling
14 years ago

  • Milestone changed from 1.2 to 1.3

As much as I want to fix this now, it's actually part of a bigger problem with the way the navigation works. It's a carry over from the original theme. I'm going to punt this to 1.3, but perhaps look at the possibility of patching it in 1.2.1.

#3 @boonebgorges
14 years ago

  • Component set to Core
  • Milestone changed from 1.3 to 1.4

Looks like the problem is that the admin bar is built directly from $bp->bp_options_nav, which is dynamic in the way jjj describes.

It'd be possible to fix this with a rather kludgy conditional in bp_adminbar_account_menu(). In my view it's probably not worth putting a lot of effort into a non-kludge fix right now, given that we'll have the chance to rethink the way the admin bar is built when we begin integration with the WP 3.1 bar.

#4 @johnjamesjacoby
13 years ago

  • Component changed from Core to Groups
  • Keywords needs-patch removed
  • Milestone changed from 1.6 to 1.5
  • Resolution set to fixed
  • Severity set to normal
  • Status changed from new to closed

This was fixed in 1.5. Closing as fixed.

Note: See TracTickets for help on using tickets.