Skip to:
Content

BuddyPress.org

Opened 12 years ago

Closed 11 years ago

Last modified 6 years ago

#1557 closed enhancement (wontfix)

Comment field - click away to close textfield needed

Reported by: ezd's profile Ezd Owned by:
Milestone: 1.5 Priority: minor
Severity: normal Version:
Component: Templates Keywords:
Cc:

Description

I think it would be realllly nice if you could just start typing your comment as soon as you've clicked the reply button and if you click away the textfield would collaps/close.

Right now you have to click in the textfield first before you can type. Focus/the cursor marker should be in the textfield as soon as you've clicked the Reply button. And if you click somewhere else outside the textfield it should collaps/close.

To be include in 1.2 perhaps?

Change History (14)

#1 @Ezd
12 years ago

Update: Just tested this with Safari, Firefox and IE8. Safari and Firefox does in fact auto-focus the textfield, its just IE8 thats missing autofocus. Close/collaps textfield when clicking away is missing.

#2 @Ezd
12 years ago

  • Summary changed from Comment field - auto focus and click away to close to Comment field - click away to close textfield needed

#3 @apeatling
12 years ago

  • Resolution set to fixed
  • Status changed from new to closed

The comment box gets the focus, you can hit esc to close.

#4 @haloid
12 years ago

  • Priority changed from major to minor
  • Resolution fixed deleted
  • Status changed from closed to reopened

I think this enhancement is for the "clicking away" action, i.e. click anywhere outside the commenting area and it will close the text box. So users won't have to reach forward for the Esc button on their keyboard.

#5 @Ezd
12 years ago

Thats right haloid. I bet it's VERY few people that will actually reach out and hit the ESC key.

You need to be able to click elsewhere outside the textfield to close it. Thats pretty standard in many communities I've seen, including facebook I think.

Would be very nice that you can control this with just your mouse.

#6 @Ezd
12 years ago

Confirmed - Also on Facebook you can "unfocus and close" the textfield by clicking elsewhere with your mouse. It's just a nice undo action to have which is quicker then ESC.

#7 @Ezd
12 years ago

I think you could put it this way too. Pressing the "ESC" key on your keyboard is a more "geeky" approach to close the textfield. Clicking away with your mouse is quicker and more user friendly. ;)

#8 @haloid
12 years ago

By the way, on IE8 the text box still doesn't get the focus.

PS: If not "if unfocused then close" then maybe a "Cancel" button? ;-)

#9 @DJPaul
12 years ago

  • Keywords dev-feedback added
  • Milestone changed from 1.2 to 1.2.1

I think just because Facebook does something one way doesn't mean the BuddyPress should do it the same way. Bumping to 1.2.1 for comment from apeatling or jjj.

#10 @boonebgorges
12 years ago

  • Component set to Core

I don't really care too much about this one way or another. There's a 'or press esc to cancel' message by the Post button, which seems fine to me. Clicking outside the box and having it close seems like it's just as likely to cause people to accidentally close the reply window.

If I were pressed to decide, I'd say leave it like it is. Or maybe change the 'esc' message to a full-fledged Cancel button/link.

#11 @DJPaul
11 years ago

  • Milestone changed from 1.3 to Awaiting Review

#12 @DJPaul
11 years ago

  • Keywords dev-feedback removed
  • Resolution set to wontfix
  • Status changed from reopened to closed

Per Boone's comments above, clicking outside of the box and having it close seems as thought it would likely cause people to accidentally close the reply window. This sort of change can be easily implemented into a child theme if a specific site desires this functionality.

#13 @johnjamesjacoby
11 years ago

  • Component changed from Core to Theme
  • Milestone changed from Awaiting Review to 1.5
  • Severity set to normal

Moving closed ticket out of Awaiting Review.

#14 @DJPaul
6 years ago

  • Component changed from Appearance - Template Parts to Templates
Note: See TracTickets for help on using tickets.