Skip to:
Content

BuddyPress.org

Opened 14 years ago

Closed 14 years ago

Last modified 14 years ago

#1500 closed defect (bug) (no action required)

error in bp_loggedinuser_link function

Reported by: fairweb's profile Fairweb Owned by:
Milestone: 1.2 Priority: trivial
Severity: Version:
Component: Keywords: templatetags
Cc:

Description

in bp-core-templatetags.php, function bp_loggedinuser_link has bad operator.

It says

if ( $link = bp_core_get_userlink( $bp->loggedin_user->id ) )

It should say

if ( $link == bp_core_get_userlink( $bp->loggedin_user->id ) )

and not =

Change History (2)

#1 @sbrajesh
14 years ago

  • Priority changed from major to trivial
  • Resolution set to invalid
  • Status changed from new to closed

This is not a bug, It is an assignment not a comparison, sometimes, developers do this to save some code.It is not a bug.

#2 @Fairweb
14 years ago

OK thanks for your time and for your explanation. Sorry if I misunderstood the context.

Note: See TracTickets for help on using tickets.