Skip to:
Content

Opened 4 years ago

Closed 13 months ago

#1356 closed defect (bug) (worksforme)

Usernames with @ redirect to home rather than profile/edit profile

Reported by: ersavla Owned by:
Milestone: Priority: major
Severity: normal Version:
Component: Core Keywords:
Cc: ersavla

Description

Using WPMU 2.8.4 and BP 1.1.2, some username links from the member directory fail to navigate to the member profile, but return you to the home page, instead. No error reported.

outolumo reported this behavior at http://buddypress.org/forums/topic/trouble-with-sign-in-the-username; I've got the same problem.

The @-symbol appears to be the difference between username links in the directory that successfully bring you to the member's profile, and those that don't.

(Why it's key, to us anyway: We need to use email as username, without major hacks to make it work. For our use, I haven't come across any WPMU-based blockades on this. Outolumo's workaround doesn't happen to work, given our user base and use case. Admins establish our user accounts, not users via registration.)

Change History (7)

comment:1 apeatling4 years ago

  • Resolution set to invalid
  • Status changed from new to closed

If you are allowing @ symbols in usernames, then please add this to your wp-config.php:

define( 'BP_ENABLE_USERNAME_COMPATIBILITY_MODE', true );

http://codex.buddypress.org/how-to-guides/changing-internal-configuration-settings/

Please re-open if this does not work correctly for you.

comment:2 ersavla4 years ago

  • Cc ersavla added
  • Resolution invalid deleted
  • Status changed from closed to reopened
  • Summary changed from Usernames with @ redirect to home rather than profile to Usernames with @ redirect to home rather than profile/edit profile

Adding the definition to the wp-config.php solved the problem of navigating to the profile from the directory. However, now seeing similar behavior when:

--> logged in as site admin, trying to navigate from profile > Admin Options > Edit {username}'s Avatar or Edit {username}'s Profile.

--> logged in as user with an email-based username, trying to navigate to My Account > Profile > Edit Profile OR trying the Edit Profile button or menu option from within profile itself.

In each case, the site redirects to the home page rather than the Edit Profile interface.

Accounts with other types of usernames (straight alpha) DO reach the Edit Profile interface.

Thanks for your help!

comment:3 dpolant4 years ago

With @ sign usernames, I am able to get to the edit screen, but the edit action is causing a redirect to home. The action is completing successfully though.

I echoed some of the server request uris and found that something stripping out the @ sign.

comment:4 dpolant4 years ago

Update:

This problem is caused by a wp_sanitize_redirect. You'll probably want to override this function in bp-core (if they have the username compatibility constant enabled). I'll come up with some code as soon as I can ...

comment:5 cnorris234 years ago

  • Component set to Core
  • Milestone set to Future Release

comment:6 ubernaut13 months ago

  • Keywords dev-feedback added
  • Severity set to normal

i dont eve see these users in the directory under trunk 6846

comment:7 r-a-y13 months ago

  • Keywords username profile email dev-feedback removed
  • Milestone Future Release deleted
  • Resolution set to worksforme
  • Status changed from reopened to closed

The problems experienced by ersavia should be fixed as of BP 1.7.

Note: See TracTickets for help on using tickets.