Skip to:
Content

BuddyPress.org

Opened 11 years ago

Closed 11 years ago

#1343 closed defect (bug) (fixed)

Delete links displayed in error on my friends' activity stream

Reported by: swinton Owned by:
Milestone: 1.1.3 Priority: major
Severity: Version:
Component: Keywords: activity, friends, has-patch
Cc:

Description

I have tested this on my local installation, and on testbp.org, and am able to reproduce on both instances.

When viewing my friend's activity (e.g. http://testbp.org/members/swinton/activity/my-friends/), 'Delete' buttons are shown next to all activities, however clicking 'Delete' just takes me to the home page as I don't have permissions to delete any of these activities.

I believe the 'Delete' buttons are being displayed due to $bp->is_item_admin being set incorrectly in bp_core_setup_globals().

The value of is_item_admin is set to the return value of bp_is_home(), which is invalid when looking at friend's activity.

A possible patch for this issue is attached.

Attachments (1)

bp-core.php.patch (741 bytes) - added by swinton 11 years ago.
Patchfile for revision 2089 of bp-core.php

Download all attachments as: .zip

Change History (3)

@swinton
11 years ago

Patchfile for revision 2089 of bp-core.php

#1 @r-a-y
11 years ago

  • Keywords has-patch added
  • Milestone changed from Future Release to 1.1.3

#2 @apeatling
11 years ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [2109]) Fixes #1343

Note: See TracTickets for help on using tickets.