Skip to:
Content

BuddyPress.org

Opened 13 years ago

Closed 12 years ago

Last modified 6 years ago

#1339 closed enhancement (no action required)

Unicode characters in URL converted to escape character and lead to 400 Bad Request

Reported by: andrepan's profile andrepan Owned by:
Milestone: Priority: major
Severity: Version:
Component: Keywords: bug, error, blog, buddypress
Cc:

Description

BuddyPress 1.1.2/WPMU 2.8.5.2


Chinese characters in pingback URL on blog is converted to escape character, clicking the URL will lead to a 400 Bad Request page


Example:
http://abc.com/blog/2009/11/11/解决-buddypress-1-1-2-首页全站动态-widget-的中文字符-url-乱码问题/
converted to
http://abc.com/blog/2009/11/11/%e8%a7%a3%e5%86%b3-buddypress-1-1-2-%e9%a6%96%e9%a1%b5%e5%85%a8%e7%ab%99%e5%8a%a8%e6%80%81-widget-%e7%9a%84%e4%b8%ad%e6%96%87%e5%ad%97%e7%ac%a6-url-%e4%b9%b1%e7%a0%81%e9%97%ae%e9%a2%98/

Usually escape code in URL won't make any problem, but I don't know why this happens, is that something about server setting?

Change History (4)

#1 @andrepan
13 years ago

  • Resolution set to invalid
  • Status changed from new to closed

Oh, I see, the long url was cut down by character number limitation, so it's not a bug anyway

#2 @andrepan
13 years ago

  • Resolution invalid deleted
  • Status changed from closed to reopened

The problem is generated by the 200-character length limitation of pingback url, so anybody know how to hack this limitation? I've changed wp_comments -> comment_author_url from VARCHAR(200)to VARCHAR(255), should have some function hacked for this to work.

#3 @apeatling
12 years ago

  • Resolution set to invalid
  • Status changed from reopened to closed

Please take this up on WP core trac.

#4 @DJPaul
6 years ago

  • Type changed from task to enhancement
Note: See TracTickets for help on using tickets.