Skip to:
Content

BuddyPress.org

Opened 13 years ago

Closed 4 years ago

#1314 closed enhancement (maybelater)

when changing group name, the slug is not changed

Reported by: k0rp0rate's profile k0rp0rate Owned by: boonebgorges's profile boonebgorges
Milestone: Priority: minor
Severity: normal Version:
Component: Groups Keywords: needs-patch, good-first-bug, trac-tidy-2018
Cc: MrMaz, r-a-y, azin@…, vivek@…

Description

If you create a group, and after that you want to rename the group... There is no problem to do it, you can change, but the group slug will be not changed.

So all users can see FOREVER the old name of the group in the group slug.

I think this is a important and basic defect that must would be solved soon.

Change History (17)

#1 @MrMaz
13 years ago

  • Cc MrMaz added
  • Keywords group slug rename support added
  • Milestone 1.1.3 deleted
  • Priority changed from major to minor
  • Type changed from defect to enhancement

This is the intended behavior. If the slug is changed then all of the external links to that group will be broken. I think this would be an enhancement to create the ability to support the renaming of a slug while still routing from "old" slugs.

#2 @k0rp0rate
13 years ago

Ok, in that case, I think that the way WordPress gives the user a field below the post/page title to edit the slug when you're in the post/page edit screen, must be the way to use in BuddyPress to change (if you want) group slug easy and fast ;)

#3 @apeatling
12 years ago

  • Milestone set to Future Release

#4 @r-a-y
12 years ago

  • Cc r-a-y added

#5 @cnorris23
11 years ago

  • Component set to Groups

#6 follow-up: @DJPaul
11 years ago

  • Milestone changed from Future Release to 1.4

This will come "for free" when we use custom post types

#7 @DJPaul
11 years ago

  • Keywords group slug rename support removed
  • Milestone changed from 1.6 to Future Release
  • Severity set to normal

#9 @DJPaul
9 years ago

Still valid, we should probably store the old slug as meta, and do a 301 redirect; just like how WP handles changes to page slugs.

#10 @boonebgorges
8 years ago

  • Owner set to boonebgorges
  • Status changed from new to assigned

Marked #2142 as duplicate

#11 @Azinfiro
8 years ago

  • Cc azin@… added

What happens if a new group takes over the old name? Do they get a number appended to their slug?

Last edited 8 years ago by Azinfiro (previous) (diff)

#12 in reply to: ↑ 6 @sooskriszta
8 years ago

Replying to DJPaul:

This will come "for free" when we use custom post types

Do we plan to use CPTs?

#13 @boonebgorges
8 years ago

  • Keywords needs-patch added

Do we plan to use CPTs?

No, but we should still do something like what DJPaul suggests https://buddypress.trac.wordpress.org/ticket/1314#comment:9

#14 @sooskriszta
8 years ago

  • Cc vivek@… added

#15 @DJPaul
6 years ago

  • Keywords good-first-bug added

#16 @DJPaul
4 years ago

  • Keywords trac-tidy-2018 added

We're closing this ticket because it has not received any contribution or comments for at least two years. We have decided that it is better to close tickets that are good ideas, which have not gotten (or are unlikely to get) contributions, rather than keep things open indefinitely. This will help us share a more realistic roadmap for BuddyPress with you.

Everyone very much appreciates the time and effort that you spent sharing your idea with us. On behalf of the entire BuddyPress team, thank you.

If you feel strongly that this enhancement should still be added to BuddyPress, and you are able to contribute effort towards it, we encourage you to re-open the ticket, or start a discussion about it in our Slack channel. Please consider that time has proven that good ideas without contributions do not get built.

For more information, see https://bpdevel.wordpress.com/2018/01/21/our-awaiting-contributions-milestone-contains/
or find us on Slack, in the #buddypress channel: https://make.wordpress.org/chat/

#17 @DJPaul
4 years ago

  • Milestone Awaiting Contributions deleted
  • Resolution set to maybelater
  • Status changed from assigned to closed
Note: See TracTickets for help on using tickets.