Skip to:
Content

Opened 4 years ago

Closed 3 years ago

#1299 closed enhancement (fixed)

site wide activity widget should aware "rel" tag

Reported by: levinng Owned by: masonjames
Milestone: 1.5 Priority: minor
Severity: Version:
Component: Activity Keywords: has-patch
Cc:

Description

I'd like to suggest site wide activity widget should allow "rel" tag for images,
it'll open up for image display plugin to work properly, such as lightbox or thickbox.

Attachments (1)

reltag.diff (568 bytes) - added by masonjames 3 years ago.
Added 'rel' attribute to the activity filter

Download all attachments as: .zip

Change History (10)

comment:1 apeatling4 years ago

  • Milestone set to 1.2
  • Type changed from enhancement to defect

Will add support for this in 1.2.

comment:2 apeatling4 years ago

  • Keywords needs-patch added

Need a patch for this.

comment:3 apeatling4 years ago

  • Milestone changed from 1.2 to 1.2.1
  • Type changed from defect to enhancement

Bumping to 1.2.1.

comment:4 boonebgorges3 years ago

  • Component set to Core
  • Milestone changed from 1.3 to 1.4

There is no sitewide activity widget in BP anymore, though I assume the issue is more broadly relevant.

Punting to 1.4 in the absence of a patch. If anyone wants to step up, please feel free to bump this back to 1.3.

comment:5 DJPaul3 years ago

I assume this would just involve adding the rel tag to the bp_activity_filter_kses() filter? Easy props for someone if they would like to patch it.

comment:6 masonjames3 years ago

  • Owner set to masonjames
  • Status changed from new to accepted

masonjames3 years ago

Added 'rel' attribute to the activity filter

comment:7 masonjames3 years ago

  • Keywords has-patch added; needs-patch removed
  • Resolution set to fixed
  • Status changed from accepted to closed

Here's my first patch. Feel free to let me know if I've done it incorrectly :)

comment:8 boonebgorges3 years ago

  • Component changed from Core to Activity
  • Milestone changed from 1.4 to 1.3
  • Priority changed from major to minor
  • Resolution fixed deleted
  • Status changed from closed to reopened

Thanks for the patch, I'll have a look shortly.

comment:9 boonebgorges3 years ago

  • Resolution set to fixed
  • Status changed from reopened to closed

Looks like this is already done in the trunk, as of r3494.

Note: See TracTickets for help on using tickets.