Skip to:
Content

Opened 9 years ago

Closed 9 years ago

#1286 closed defect (bug) (fixed)

Activity feed pubDate tag showing oldest date instead of newest

Reported by: MrMaz Owned by: MrMaz
Milestone: 1.2.6 Priority: minor
Severity: Version:
Component: Core Keywords: has-patch activity feed pubdate order sort
Cc:

Description

Title says it all. I think this line should order by DESC not ASC

http://trac.buddypress.org/browser/trunk/bp-activity/bp-activity-classes.php#L326

Attachments (1)

1286.patch (986 bytes) - added by MrMaz 9 years ago.

Download all attachments as: .zip

Change History (12)

@MrMaz
9 years ago

#1 @MrMaz
9 years ago

  • Keywords has_patch added
  • Owner set to MrMaz
  • Status changed from new to accepted

#2 @MrMaz
9 years ago

  • Milestone set to 1.1.3

#3 @MrMaz
9 years ago

  • Keywords has-patch added; has_patch removed

#4 @johnjamesjacoby
9 years ago

Can you show me a place on testbp.org where the activity shows up in the wrong order?

#5 @MrMaz
9 years ago

  • Status changed from accepted to assigned

Sure. And actually, its not the sort order, its the pubDate tag in the feed header.

Load this up and view the XML source:
http://testbp.org/activity/feed

Grep for "pubDate"

More info on pubDate in the spec:
http://validator.w3.org/feed/docs/rss2.html

Technically your pubDate is supposed to be once or twice a day, but the bp activity class is using the date of the most recent update. I am not even sure if most feed readers use pubDate, but BP should try to follow the spec.

#6 @apeatling
9 years ago

  • Milestone changed from 1.1.3 to Future Release

#7 @MrMaz
9 years ago

All BP activity feeds are breaking RSS spec because of this issue. Why not fix it asap?

I spent a lot of time researching this one, a comment would be appreciated.

#8 @DJPaul
9 years ago

  • Component set to Core
  • Milestone changed from Future Release to 1.3

MrMaz would you take a look at this please?

#9 @r-a-y
9 years ago

Re: http://trac.buddypress.org/ticket/1286#comment:5

Confirmed on testbp.org.
pubDate shows Jan 1, 1970.

#10 @r-a-y
9 years ago

  • Milestone changed from 1.3 to 1.2.6

Moving this to 1.2.6 because it's a valid issue and a simple fix.

AFAIK, the function, BP_Activity_Activity::get_last_updated() is only used for the activity RSS feeds.

#11 @johnjamesjacoby
9 years ago

  • Resolution set to fixed
  • Status changed from assigned to closed

(In [3115]) Fixes #1286 props MrMaz

Note: See TracTickets for help on using tickets.