Skip to:
Content

Opened 9 years ago

Closed 9 years ago

#1277 closed defect (bug) (no action required)

"Latest Post" Permalink in [Blogs] page is wrong

Reported by: levinng Owned by:
Milestone: 1.2 Priority: major
Severity: Version:
Component: Keywords: permalink
Cc:

Description

When member's blog permalink set to "/%category%/%postname%/",
every member's "Latest Post" (except main blog) permalink in [Blogs] page is set to

http://domain.com/membername/<latest category name from main blog>/postname

Change History (15)

#1 @johnjamesjacoby
9 years ago

Can anyone else confirm this?

Tested on testbp.org with permalinks set that way before and after making a new post. Also testing on my dev environment and cannot reproduce the problem.

All links to posts appear correct in testbp.org/blogs, and when viewing a users blogs/recent-posts/ pages.

Check johnjamesjacoby.testbp.org and look at my blog posts. If there is a place where this error occurs, please link me directly to it.

#2 @johnjamesjacoby
9 years ago

  • Resolution set to worksforme
  • Status changed from new to closed

Marked as "worksforme" until can be duplicated.

#3 @levinng
9 years ago

  • Resolution worksforme deleted
  • Status changed from closed to reopened

I could narrow down a bit on the problem, i try to setup a new installation with sud-domain setting in mu, i found the there is no issues on permalink, and i make a sub-directories setting installation again, problem happen.

#4 follow-up: @andrea_r
9 years ago

If you can turn Buddypress off and get the same issue, then file the trac ticket over at http://trac.mu.wordpress.org/ becasue then it would be a WPMU issue.

#5 in reply to: ↑ 4 @levinng
9 years ago

Replying to andrea_r:

If you can turn Buddypress off and get the same issue, then file the trac ticket over at http://trac.mu.wordpress.org/ becasue then it would be a WPMU issue.

It could be a issue on buddypress core, because the permalink is work fine on site-wide-activity widget or another third party widget...

#6 @johnjamesjacoby
9 years ago

Okay, so it's sub directory only. Good info.

#7 @apeatling
9 years ago

  • Milestone set to 1.1.3

#8 @apeatling
9 years ago

  • Resolution set to worksforme
  • Status changed from reopened to closed

I can't reproduce this. Please provide step-by-step instructions to reproduce.

#9 follow-up: @levinng
9 years ago

  • Resolution worksforme deleted
  • Status changed from closed to reopened

@andy

  1. setup sub-domain configuration bp+MU
  2. Create a "Post Category" called [MYCAT1] on main blog
  3. Create a userX with blog enabled
  4. Use that userX to post a blog post(my post 1) without giving it an Category.
  5. Navigate to buddypress [Blogs] page, the userX latest post was given a permalink http://domain.com/userX/MYCAT1/my-post-1

Second case,
Step 4. Use that userX to post a blog post(my post 2) with specifying a Category

  1. Navigate to buddypress [Blogs] page, the userX latest post was given a permalink

http://domain.com/userX/uncategorized/my-post-2/

It only happen on sub-domain MU configuration.

#10 in reply to: ↑ 9 ; follow-up: @levinng
9 years ago

Replying to levinng:

@andy

  1. setup sub-domain configuration bp+MU
  2. Create a "Post Category" called [MYCAT1] on main blog
  3. Create a userX with blog enabled
  4. Use that userX to post a blog post(my post 1) without giving it an Category.
  5. Navigate to buddypress [Blogs] page, the userX latest post was given a permalink http://domain.com/userX/MYCAT1/my-post-1

Second case,
Step 4. Use that userX to post a blog post(my post 2) with specifying a Category

  1. Navigate to buddypress [Blogs] page, the userX latest post was given a permalink

http://domain.com/userX/uncategorized/my-post-2/

It only happen on sub-domain MU configuration.

sub-domain configuration , sorry it is sub-direcotry configuration MU

#11 in reply to: ↑ 10 @levinng
9 years ago

sub-domain configuration , sorry it is sub-direcotry configuration MU

and
both main blog and userX permalink setting is set to /%category%/%postname%/

#12 @apeatling
9 years ago

  • Priority changed from critical to major

Still struggling to reproduce this, can anyone else reproduce this using the above steps?

#13 @levinng
9 years ago

After hours hacking and var dumping, i found that the line 744 in bp-blogs-templatetags calling the core WP get_the_category which is always getting the root blog term meta instead of individual's meta when my MU configuration is set to sub-directory.

#14 @apeatling
9 years ago

  • Milestone changed from 1.1.3 to 1.2

Thanks for the debugging, this is a bigger issue that there is time for in 1.1.3 so I'm bumping this to 1.2 so it can be looked at in more detail.

#15 @apeatling
9 years ago

  • Resolution set to invalid
  • Status changed from reopened to closed

This page has been removed and essentially been deprecated in 1.2 as the activity stream with a "Blog Posts" filter will be used to show a user's latest post.

Note: See TracTickets for help on using tickets.