Skip to:
Content

Opened 5 years ago

Closed 4 years ago

#1265 closed defect (bug) (fixed)

Dashboard Add User email URL borked with BuddyPress 1.1.1 active

Reported by: dnorman Owned by:
Milestone: 1.1.3 Priority: major
Severity: Version:
Component: Keywords:
Cc: mlovelock

Description

I posted this initially as a response on another thread, but that thread was about the Welcome Pack, and the problem I'm seeing is completely separate from Welcome Pack, so I'm reposting it here for clarification.

The Dashboard Add Users feature has been broken on my site for awhile now, and I've been trying to follow the code and various string replacements, to see what the cause is. The problem we're having is the email confirmation that is sent out after using Dashboard > Add User contains a broken string replacement, and no URL to click.

I just tried a fresh install of WPMU (2.8.4a) and tested Dashboard > Users > Add User (worked fine, email arrived intact).

After installing and enabling BuddyPress 1.1.1, doing the same thing to Add User results in a borked email:

`
Hi,
You've been invited to join 'WPMU Test Blogs' at
http://myserver.ca/wpmu as a subscriber.
If you do not want to join this blog please ignore
this email. This invitation will expire in a few days.

Please click the folowing link to activate your user account:
%s
`
The last %s isn't being substituted by the activation link.

I've tried following the various filters and functions, but can't seem to nail it down. The problem disappears if BuddyPress is disabled.

Change History (5)

comment:1 mlovelock4 years ago

  • Cc mlovelock added

Issue still prevalent in BuddyPress 1.1.2 - again from the Dashboard > Users > Add User menu.

Dashboard > Siteadmin > Users > Add User works fine, as does the BuddyPress registration process

comment:2 follow-up: johnjamesjacoby4 years ago

I think this is a WPMU issue with the %%s.

Try the patch below and see if it helps?

http://trac.mu.wordpress.org/attachment/ticket/1145/admin_created_user_email.patch

comment:3 in reply to: ↑ 2 copgarden4 years ago

I've been having this problem as well. Patch didn't work for me; I'm on wp2.8.5.2 bp 1.1.2.

Browser returned sprintf() too few arguments in /home/copgarde/public_html/wp-admin/user-new.php on line 26 plus header errors upon clicking "add user".
Blog invite email was empty. I had clicked "skip activation email" so I don't think this email should have been sent, but in it's place the email containing username/pw.

comment:4 apeatling4 years ago

  • Milestone set to 1.1.3

comment:5 apeatling4 years ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [2101]) Fixes #1265

Note: See TracTickets for help on using tickets.