Skip to:
Content

Opened 9 years ago

Closed 9 years ago

#1201 closed defect (bug) (no action required)

Wire: text field for writing a wire is behaving strange

Reported by: erich73 Owned by:
Milestone: 1.2 Priority: minor
Severity: Version:
Component: Keywords: reporter-feedback
Cc: johnjamesjacoby

Description

when writing a Wire-post at one friends wire, then written text is behaving strange.

When I want to change the text within the field (during writing the message) then for example I move the cursor to a specific letter within the text. Then I click on the "delete"-key at my keynoard in order to delete one specific letter of the text.
Then the issue is that this specific letter is NOT getting deleted, but the cursor is hopping to the end of the text-message.

Something is clearly wrong with this text-field. It is not behaving like a normal text-field. Is there any AJAX-bug in there ?

Not sure why the height of that field is also so small, so that user has difficulties to scroll up and down....

Change History (7)

#1 @erich73
9 years ago

additional note:
this issue happens BEFORE posting the message (just when writing and editing the text).

I just discovered where the issue might be coming from:
when I am at the end of my text (at the bottom of the message), then I move my mouse-cursor out of the field: then the text-message is hopping to the top of the text.
This might be a nice feature, but is most probably causing those issues when trying to edit the text.

#2 @DJPaul
9 years ago

  • Keywords reporter-feedback added
  • Priority changed from major to minor

Seems perfectly OK to me. Which browser are you using?

#3 @erich73
9 years ago

have you tested this ?

this is not a browser-issue !
This is a JavaScript issue within the Wire-Field at the "Group Wire".

Why messing-up a simple form-field with Java-Script code ?
Sometimes, less is MORE.....

#4 @DJPaul
9 years ago

Of course I check every ticket. It took me an entire evening to do all the 1.1.2 tickets the other night, and I was unable to create this one.

#5 @johnjamesjacoby
9 years ago

  • Cc johnjamesjacoby added
  • Resolution set to worksforme
  • Status changed from new to closed

Can't duplicate this one myself either, on neither friends nor groups wire.

Reopen if you have a URL with an example I can test this at.

#6 @erich73
9 years ago

  • Resolution worksforme deleted
  • Status changed from closed to reopened

the issue is the following:

when you are WITHIN the text-field at line 3 of 4 (when you write a text which is 3 of 4 lines long), then of course you are at the END of your text.

Then, when you move the mouse-cursor OUT OF THE TEXT field, then the text within the field is moving to the TOP of the field.

You have JacaScript in there which makes the text hopping up to the TOP within the field, when you move your mouse-cursor OUT of the field.

#7 @erich73
9 years ago

  • Resolution set to invalid
  • Status changed from reopened to closed

this is done, as "WIRE"-feature has been removed from the system.

Thanks !

Note: See TracTickets for help on using tickets.