Skip to:
Content

BuddyPress.org

Opened 15 years ago

Closed 15 years ago

#117 closed defect (bug) (fixed)

404 Not Found on all pages

Reported by: bercon's profile bercon Owned by:
Milestone: Priority: major
Severity: Version:
Component: Keywords: 404
Cc:

Description

All BuddyPress pages like the following displays with a "404 Not Found" HTTP-header:
http://testbp.org/members/membername
http://testbp.org/members/membername/profile
http://testbp.org/members/membername/activity
http://testbp.org/members/membername/wire
http://testbp.org/members/membername/friends
etc.

That will prevent the search engines from indexing all those pages. Make them display with a "200 OK" HTTP-header instead.

Change History (4)

#1 @apeatling
15 years ago

  • Resolution set to fixed
  • Status changed from new to closed

Fixed in r443.

Can you confirm this is fixed based on your findings? I want to make sure we are seeing the same thing.

#2 @bercon
15 years ago

Yes, it seems to work fine now. I get 200 OK on all member pages.

#3 @apeatling
15 years ago

  • Resolution fixed deleted
  • Status changed from closed to reopened

Adding <?php header( 'Status: 200 OK', true, 200 ); ?> fixes this problem, however it is causing other problems:

  • Users are receiving a "Document has moved here" message when visiting some links
  • The last step of group creation no longer redirects to the new group on completion.

Need to figure out why these two things are happening before this can be marked as fixed again.

#4 @apeatling
15 years ago

  • Resolution set to fixed
  • Status changed from reopened to closed

Groups are working with this set again. Document moved errors are caused by server misconfiguration and not BuddyPress.

Note: See TracTickets for help on using tickets.