Skip to:

Opened 6 years ago

Closed 6 years ago

#1147 closed defect (bug) (invalid)

1.0.3 to 1.1 upgrade kills group avatars

Reported by: takuya Owned by:
Milestone: 1.1.1 Priority: major
Severity: Version:
Component: Keywords: group, avatar


I've completely managed to upgrade to 1.1 with everything working fine, except uploaded group avatars not working. When I checked the source, src= property is empty. Member avatars are working fine.

Attachments (2)

2009-10-02_143252.jpg (9.6 KB) - added by takuya 6 years ago.
2009-10-02_143153.jpg (15.7 KB) - added by takuya 6 years ago.

Download all attachments as: .zip

Change History (6)

@takuya6 years ago

@takuya6 years ago

comment:1 @takuya6 years ago

  • Priority changed from minor to major

1.0.3 and 1.1 generates totally different type of images, that's why previously uploaded group avatars are not displayed correctly.

1.0.3 generates:

1.1 generates:

For future releases, you should decide either to use full or bpfull.

comment:2 @DJPaul6 years ago

BP 1.1 is using 'bpfull' and 'bpthumb', so you can assume these will be used in future. Keep discussion on this on

comment:3 @takuya6 years ago

Then we'd need a little script to change file names after upgrade.

comment:4 @apeatling6 years ago

  • Resolution set to invalid
  • Status changed from new to closed

There is an upgrade function in bp-groups.php that renames and moves the images. If this didn't happen when you upgraded then there is probably a permissions problem.

This forum post contains the script:

Note: See TracTickets for help on using tickets.