Skip to:
Content

Opened 5 years ago

Closed 4 years ago

#1139 closed enhancement (invalid)

Post-Reply-link (Forum) / no landing-page when not being logged-in

Reported by: erich73 Owned by: johnjamesjacoby
Milestone: 1.2 Priority: major
Severity: Version:
Component: Keywords: needs-patch
Cc:

Description

when NOT being logged-in:

clicking the link "Post Reply" (within the Forum) does not do anything.

Solution:
it should forward to a "Registration"-page or to a "Sign-in"-page.
Currently, people are confused, because they are clicking on this "Post Reply"-link but nothing is happening.

Please see screenshot attached.

Attachments (2)

post_reply_not_logged_in.gif (104.6 KB) - added by erich73 5 years ago.
no-user-no-post.patch (1.7 KB) - added by johnjamesjacoby 5 years ago.
Not logged in? Don't show links…

Download all attachments as: .zip

Change History (13)

comment:1 erich735 years ago

when NOT being logged-in:

clicking the link "Post Reply" (within the Forum) does not do anything.

Solution:
it should forward to a "Registration"-page or to a "Sign-in"-page.
Currently, people are confused, because they are clicking on this "Post Reply"-link but nothing is happening.

Please see screenshot attached.

same issue for "Post New"-link within the Forum.

At least, the people should get a message saying "Please register" or "Please "Sign-in".

comment:2 apeatling5 years ago

  • Priority changed from critical to major

johnjamesjacoby5 years ago

Not logged in? Don't show links...

comment:3 johnjamesjacoby5 years ago

  • Keywords has-patch added
  • Owner set to johnjamesjacoby
  • Status changed from new to assigned

Accidentally attached this patch to 1140.

Quick fix for 1.1.1, but maybe needs a function with a redirect to register andor/login page later on?

comment:4 apeatling5 years ago

  • Resolution set to fixed
  • Status changed from assigned to closed

(In [2028]) Fixes #1139 props jjj

comment:5 erich735 years ago

  • Resolution fixed deleted
  • Status changed from closed to reopened

I do not see the fix at
www.testbp.org

Is this website not updated yet ?

Thanks !

comment:6 DJPaul5 years ago

  • Resolution set to fixed
  • Status changed from reopened to closed

Please don't reopen closed tickets unless, in this case, the patch doesn't work. I believe testbp.org to update every so often and as such isn't a good way to confirm if this fix works as you expected it to; you need to test on your own install if you want to check.

comment:7 erich735 years ago

sorry, Iam just trying to help and report bugs.
Updating testbp.org is the best way to test BP-software independently and check for bugs.

comment:8 apeatling5 years ago

This is fixed, please leave a couple of hours before checking testbp.org to make sure it has been updated.

comment:9 erich735 years ago

  • Milestone changed from 1.1.1 to 1.1.2
  • Resolution fixed deleted
  • Status changed from closed to reopened
  • Type changed from defect to enhancement

when not being logged-in:

having the "Post Reply"-link and the "Post New"-link within the Forums (when not being logged-in) was a very nice and logic feature. Why did you delete those links ?

Clicking on "Post Reply" or "Post New" and then being forwarded to the "Registration"-page" or "Sign-in"-page would eliminate a lot of confusion for new users.

comment:10 DJPaul5 years ago

  • Keywords needs-patch added; has-patch removed
  • Milestone changed from 1.1.2 to 1.2

comment:11 apeatling4 years ago

  • Resolution set to invalid
  • Status changed from reopened to closed

Invalid in 1.2.

Note: See TracTickets for help on using tickets.