Skip to:

Opened 15 years ago

Closed 15 years ago

Last modified 15 years ago

#1133 closed defect (bug) (no action required)

Site Wide Activity widget shows first picture from library at every item

Reported by: pavelevap's profile pavelevap Owned by:
Milestone: 1.2 Priority: major
Severity: Version:
Component: Keywords:
Cc: pavelevap@…, pavelevap


Hi, my site wide activity widget shows first picture from my media library at every item (example

Change History (11)

#1 @pavelevap
15 years ago

UPDATE: This problem appears only for old activity items. As soon as you add new activity items (posts, wire info, etc.) then these items do not have this picture. But all old items have this picture (first from Media Library) attached...

#2 @johnjamesjacoby
15 years ago

That's a strange result to what's happening...

Looks to me like you haven't deleted your bp-themes folder yet, or upgraded your themes to 1.1. Can you do this first and reply back with the result?

#3 @pavelevap
15 years ago

Yes, deleted. I use only default theme without custom changes. It is very strange... I can give you login to test it. I thougt that it could be caused by Custom Fields Image plugin (, but I deactivate it and delete all values (but it looks like there are old values somewhere hidden even if plugin deactivated). But I am not sure... Thank you for your help...

#4 @johnjamesjacoby
15 years ago

It's possible that plugin is the cause of your issues. With 1.1 the activity is ran through the 'the_content' filter.

Are you comfortable testing something with me? Since your site is the first case of this I've seen I'd like to try something with you.

In bp-activity-templatetags.php, can you comment out line 255, so that it looks like:

254:		/* Add 'the_content' filter to activity to allow existing plugins to replace text as they would on post text. (extra smilies etc) */
255:		// $content = apply_filters( 'the_content', $content );

#5 @apeatling
15 years ago

  • Resolution set to invalid
  • Status changed from new to closed

Marking as invalid until further feedback.

#6 @pavelevap
15 years ago

I tried to comment this line, but there is no change in template. It is very strange because plugin is no longer active... I also asked author of this plugin to look into it... And when I used BuddyPress 1.0.3 there were no problem...

#7 @pavelevap
15 years ago

  • Cc pavelevap added
  • Milestone changed from 1.1.1 to 1.1.2
  • Resolution invalid deleted
  • Status changed from closed to reopened

I further investigated this problem because it still appears on my website (even if plugin is deactivated):

I searched database for these strange pictures and in wp_bp_xprofile_wire table there is only text, that is right, but in the table wp_bp_activity_user_activity_cached there is this strange picture inserted. How could be inserted here automatically? And could be wire regenerated to remove this picture?

I think that I partly understand how it was caused. I used plugin Custom Fields Image (some kind of post thumbnails using WordPress custom fields), which has also possibility to use first picture from post gallery when there is no picture selected. These pictures are probably generated somehow through the_content() filter and during upgrading BudyPress were somehow cached into wire (wp_bp_activity_user_activity_cached). But it should not, because this plugin is only for posts. So these strange pictures are not generated on the fly through the_content() now, but are cached directly in database (it probably happenned during BuddyPress upgrade).

So, is it possible to repair it somehow automatically (without manually modifying database)? And how to stop these problems in the future? It is probably common problem with using the_content() filter for site wide activity widget in newest version of BuddyPress...

Thank you for your help...

#8 @DJPaul
15 years ago

You should be able to empty the contents of your _cached database tables because they are only a cache and will be regenerated eventually anyway. Best to back up your database first, just in case.

#9 @pavelevap
15 years ago

I tried to rename this table, but was not regenerated (I tried also deactivate and activate BuddyPress).

#10 @johnjamesjacoby
15 years ago

  • Resolution set to invalid
  • Status changed from reopened to closed

Marking this as invalid again. Plugin conflicts can happen, but this just seems like the plugin is doing exactly like it advertises it will do.

If a plugin is hooking into the_content() and displaying an image for you if no image is available, then that's exactly the problem you're experiencing. I think this is an isolated issue that may need to be revisited by the author of the plugin you're using, at least until more issues or scenarios come through with this.

#11 @pavelevap
15 years ago

No, it is not plugin conflict, but it is problem of BuddyPress. But I will leave this closed, because there is better ticket related to this issue:

Note: See TracTickets for help on using tickets.