Skip to:
Content

Opened 10 years ago

Closed 10 years ago

#1029 closed defect (bug) (fixed)

adding xprofile options duplicates existing last option's id

Reported by: junsuijin Owned by: junsuijin
Milestone: 1.1 Priority: major
Severity: Version:
Component: Keywords: has-patch, tested
Cc:

Description

Create or use an existing, optionable xprofile field, and save it after making sure it has at least 1 filled-in option. Leaving the page and coming back in, try to add a new option and the id number will repeat the id of the lattermost saved option, which causes the 2nd instance to overwrite the first on save. Included patch fixes the issue.

Attachments (1)

fix-new-option-ids.patch (820 bytes) - added by junsuijin 10 years ago.

Download all attachments as: .zip

Change History (3)

#1 @junsuijin
10 years ago

Further complications are also caused by this same issue, whereby a user will be unable to save any changes to option #1 without first adding a new option #1.

#2 @apeatling
10 years ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [1901]) Fixes #1029 props junsuijin

Note: See TracTickets for help on using tickets.