Skip to:
Content

BuddyPress.org


Ignore:
Timestamp:
04/30/2015 08:21:26 PM (6 years ago)
Author:
imath
Message:

Avatar UI : make sure the current site is using at least WordPress 3.9

To maximize browsers compatibility, the Avatar UI requires Pluload 2.1.1. This version of the script was introduced in version 3.9 of WordPress.
For WordPress versions 3.6 to 3.8, the legacy UI will be used.

Fixes #6290

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/src/bp-core/bp-core-attachments.php

    r9826 r9827  
    99// Exit if accessed directly
    1010defined( 'ABSPATH' ) || exit;
     11
     12/**
     13 * Check if the current WordPress version is using Plupload 2.1.1
     14 *
     15 * Plupload 2.1.1 was introduced in WordPress 3.9. Our bp-plupload.js
     16 * script requires it. So we need to make sure the current WordPress
     17 * match with our needs.
     18 *
     19 * @since  BuddyPress (2.3.0)
     20 *
     21 * @return bool True if WordPress is 3.9+, false otherwise
     22 */
     23function bp_attachments_is_wp_version_supported() {
     24    return (bool) version_compare( bp_get_major_wp_version(), '3.9', '>=' );
     25}
    1126
    1227/**
Note: See TracChangeset for help on using the changeset viewer.