Skip to:
Content

BuddyPress.org

Changeset 8515


Ignore:
Timestamp:
06/14/2014 06:58:11 PM (9 years ago)
Author:
boonebgorges
Message:

Only disable WP_DEBUG on PHP 5.5 Travis CI tests when running WP 3.7

This disabling is meant to allow builds to pass even in the presence of mysqli-
related debug notices. But later versions of WP either suppress the notice, or
support mysqli natively.

See #5708

Props netweb

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/.travis.yml

    r8513 r8515  
    4040    - sed -i "s/yourpasswordhere//" wp-tests-config.php
    4141    # disable WP_DEBUG for PHP 5.5 due to ext/mysqli E_DEPRECATED errors
    42     - if [[ "$TRAVIS_PHP_VERSION" == 5.5* ]] ; then sed -i "s:define( 'WP_DEBUG://define( 'WP_DEBUG:" wp-tests-config.php; fi;
     42    - if [[ "$TRAVIS_PHP_VERSION" == 5.5* ]] && [[ "$WP_VERSION" == "3.7" ]] ; then sed -i "s:define( 'WP_DEBUG://define( 'WP_DEBUG:" wp-tests-config.php; fi;
    4343    # set up database
    4444    - mysql -e 'CREATE DATABASE wordpress_test;' -uroot
Note: See TracChangeset for help on using the changeset viewer.