Skip to:
Content

BuddyPress.org

Changeset 11040


Ignore:
Timestamp:
08/30/2016 09:30:43 AM (5 years ago)
Author:
djpaul
Message:

Build: scss-lint requires Ruby >= 2.2.0

Travis-CI has started to fail because an underlying scss-lint library
we require, now requires a newer version of Ruby (at time of writing,
Ruby 1.9.3 is pre-installed on Travis-CI PHP boxes).

This change updated the Travis-CI build script to use the newer version
of Ruby. It also adds the Ruby gems cache folder to the Travis-CI job
cache to try to minimise the longer set-up time that this change has
incurred.

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/.travis.yml

    r11038 r11040  
    88
    99cache:
     10  apt: true
    1011  directories:
    1112    - $HOME/.composer/cache
     13    - $HOME/.rvm/gems
    1214#    - /tmp/wordpress/src/wp-content/plugins/buddypress/node_modules
    1315
     
    5860# before_install: Failures in this section will result in build status 'errored'
    5961before_install:
     62  # scss-lint requires Ruby >= 2.2
     63  - source ~/.rvm/scripts/rvm && rvm install 2.2.0 && rvm use 2.2.0
    6064  # set up WP install
    6165  - export WP_DEVELOP_DIR=/tmp/wordpress/
     
    8892  - mysql --version
    8993  - phpenv versions
     94  - ruby --version
    9095
    9196# before_script: Failures in this section will result in build status 'errored'
Note: See TracChangeset for help on using the changeset viewer.